1. Home
  2. Tech
  3. WhatsApp will not work on THESE smartphones from Nov 1; Here’s why

WhatsApp will not work on THESE smartphones from Nov 1; Here’s why

By Saima Siddiqui 
Updated Date
WhatsApp will not work on THESE smartphones from Nov 1; Here’s why

New Delhi: As the latest WhatsApp upgrade is set to go live on November 1, millions of people may no longer be able to use WhatsApp on their smartphones and may lose access to messages, photos, and contacts on the app. The reason for this inconvenience would be due to new WhatsApp upgrade that will bring a lot of changes, one of which will affect users who have old Android devices as well as Apple-made iOS devices with outdated operating systems.

Also Read :- WhatsApp adds 3 new features like desktop editor and more | Deets here

According to Facebook, which owns WhatsApp, smartphones using Android 4.0.3 or lower will not be supported by the messaging platform, while, in the case of Apple, the limit has been set at iOS 9 or lower. On these phones WhatsApp support will reportedly be halted, and as a result the users will have no choice but to get a new smartphone. Even though their present phone is in good working condition, this will entail a significant financial investment.

Another option for these customers is to attempt updating their phones to a higher OS version that complies with WhatsApp’s criteria.
 
While some phones may be capable of doing so, the majority will face WhatsApp restriction. To check whether or not you are safe, there are two methods:

Step 1 – Go to Settings > About phone.

Step 2 – Scroll down to look for the Android version running on your device.

Also Read :- WhatsApp adds this new feature on iOS for disappearing messages. See details

Step 3 – If it’s Android 4.0.4 or lower, you should look to switch to a device with a higher version of Android.

The second option is to look through the list of phones that will lose access to the popular messaging app:

According to WhatsApp, “The following devices are supported and recommended by us: Android versions 4.1 and up are supported. KaiOS 2.5.0 and newer, including the JioPhone and JioPhone 2. iPhone running iOS 10 and newer KaiOS 2.5.0 and newer, including the JioPhone and JioPhone 2.” WhatsApp will not work on any phones that do not have these or higher software versions.

Smartphones on which WhatsApp will stop working:

Android:

Also Read :- Book COVID-19 vaccine slots within minutes on WhatsApp: Health Minister

LG: Lucid 2, Optimus F7, Optimus F5, Optimus L3 II, Dual Optimus L5, Best L5 II, Optimus L5, Dual Best L3 II, Optimus L7, Optimus L7, Dual Best L7 II, Optimus F6, Enact Optimus F3, Best L4 II, Best L2 II, Optimus Nitro HD, Optimus 4X HD and Optimus F3Q.

Sony: Xperia Miro, Xperia Neo L, and Xperia Arc S.

Samsung: Galaxy Trend Lite, Galaxy Trend II, Galaxy SII, Galaxy S3 mini, Galaxy Xcover 2, Galaxy Core, and Galaxy Ace 2.

Huawei: Ascend G740, Ascend Mate, Ascend D Quad XL, Ascend D1 Quad XL, Ascend P1 S, and Ascend D2.

ZTE: Grand S Flex, ZTE V956, Grand X Quad V987 and Grand Memo.

Others: Alcatel, Archos 53 Platinum, HTC Desire 500, Caterpillar Cat B15, Wiko Cink Five, and Wiko Darknight, Lenovo A820 UMi X2, Run F1, THL W8.

Also Read :- WhatsApp to unveil multi-device 2.0 functionality for these devices

Apple:

iPhone 6, iPhone 6s plus, iPhone SE.

Further reading:
For the latest news and reviews, follow us on Facebook and Twitter ...